COORDINACIÓN GENERAL DE TECNOLOGÍAS DE INFORMACIÓN Y COMUNICACIÓN

Vulnerabilidad crítica en Cisco Jabber permite ejecución remota de código

Fecha de Publicación: Viernes, 4 de Septiembre de 2020

Fuente: https://unaaldia.hispasec.com/2020/09/vulnerabilidad-critica-en-cisco-jabber-permite-ejecucion-remota-de-codigo.html

3 septiembre, 2020 Por Juan José Oyagüe Leave a Comment

La vulnerabilidad, debida a una incorrecta validación de los datos de entrada, puede emplearse para ejecutar comandos del sistema en la máquina de los clientes

Investigadores de seguridad de Watchcom han descubierto cuatro vulnerabilidades en Cisco Jabber mientras realizaban una auditoría, siendo una de éstas crítica. La aplicación de mensajería instantánea es utilizada en el ámbito empresarial para comunicaciones internas, aunque puede utilizarse para hablar y conectarse a otros servidores Jabber/XMPP de fuera de la organización.

La vulnerabilidad en cuestión, con identificador CVE-2020-3495, afecta a la implementación del cliente de la extensión XEP-0071 XHTML-IM, no comprobando ni escapando los datos de entrada. Cisco Jabber utiliza para visualizar dicho XHTML la biblioteca Chromium Embedded Framework (CEF). Dicho framework no sólo permite ejecutar código JS, lo cual consistiría en una vulnerabilidad XSS, sino también realizar llamadas del sistema para ejecutar aplicaciones.

Explotación de la vulnerabilidad para abrir la calculadora de Windows del sistema. Fuente: watchcom.

Para conseguir la ejecución de código los investigadores han empleado la llamada ‘window.CallCppFunction’, incluida en el framework y la cual permite abrir archivos y ejecutar programas. En la captura superior puede observarse cómo se utiliza dicha llamada para ejecutar una aplicación. No es necesaria interacción ni aceptación por parte de la víctima para la explotación, requiriéndose sólo tener Cisco Jabber abierto.

Además de esta vulnerabilidad, se han descubierto otras tres, con identificadores CVE-2020-3430, CVE-2020-3537 y CVE-2020-3498, teniendo la primera nivel de criticidad alto y las otras dos medio. Cisco ya ha publicado actualizaciones que corrigen estos fallos en las diferentes versiones con soporte de Cisco Jabber: 12.1.3, 12.5.2, 12.6.3, 12.7.2, 12.8.3 y 12.9.1.

Se recomienda actualizar lo antes posible a una de las versiones que solucionan estos fallos o a una posterior. En caso de no ser posible, se recomienda no abrir la aplicación hasta actualizar a una versión parcheada.

Más información:

Watchom uncovers Cisco Jabber vulnerabilities:
https://watchcom.no/nyheter/nyhetsarkiv/uncovers-cisco-jabber-vulnerabilities/

Noticias Anteriores